Фрилансеры предложат решение вашей задачи уже через несколько минут!
Публикация заказа не займет много времени.
8 месяцев назад
Марат Е.
27 лет, Россия
4 года в сервисе
Был онлайн 19 дней назад
8 месяцев назад

  • Это отчёт менеджера по продажам
  • он работает всё ок
  • единственное что он берёт курс евро сегодняшнего дня
  • а не в документе поступления товара
  • когда мы его покупали.

Сама формула отчёта:
//******************************************* 
// Процедура генерации запроса Сформировать. 


Функция НайтиПоследПост(ном, регистратор) 

рег = СоздатьОбъект("Регистр.ПартииНаличие"); 
Рег.УстановитьЗначениеФильтра("Номенклатура", ном, 1); 
Кол=0; 
сум=0; 
ПослЦена =0; 

Рег.ВыбратьДвижения(); 
Пока Рег.ПолучитьДвижение() = 1 Цикл 
Если рег.Приход =1 тогда 
Кол = рег.Количество; 
сум = рег.СуммаРуб; 
регистратор = рег.ТекущийДокумент(); 
КонецЕсли; 
КонецЦикла; 

Если сум<>0 Тогда 
ПослЦена = сум/кол; 

КонецЕсли; 

// ПослЦена= Формат(ПослЦена, "Ч015.2") ; 


возврат ПослЦена; 
КонецФункции 



// 
Процедура Сформировать() 
Перем Запрос, ТекстЗапроса, Таб; 
//Создание объекта типа Запрос 


// Подготовка к заполнению выходных форм данными запроса 
Таб = СоздатьОбъект("Таблица"); 
Таб.ИсходнаяТаблица("Сформировать"); 
// Заполнение полей "Заголовок" 
Таб.ВывестиСекцию("Заголовок"); 
Состояние("Заполнение выходной таблицы..."); 
ИтогСумма=0; 
ИтогМ=0; 

док= СоздатьОбъект("Документ.Реализация"); 
Док.выбратьДокументы(ВыбНачПериода,ВыбКонПериода); 
Пока док.ПолучитьДокумент()=1 Цикл 
Если СокрЛП( ВыбПользователь) <> "" Тогда 
Если док.Автор <> ВыбПользователь Тогда 
Продолжить; 
КонецЕсли; 
КонецЕсли; 

Если СокрЛП(ВыбПроект)<>"" Тогда 
Если док.Проект <> ВыбПроект Тогда 
Продолжить; 
КонецЕсли; 
КонецЕсли; 



Если док.проведен()=0 Тогда 
Продолжить; 
КонецЕсли; 

док.выбратьстроки(); 
Пока док.получитьСтроку()=1 Цикл 

Если СокрЛП(ГруппаНом) <> "" Тогда 
Если Док.Номенклатура.ПринадлежитГруппе(ГруппаНом)=0 Тогда 
продолжить; 
КонецЕсли; 
КонецЕсли; 

регистратор=""; 
поступилоПо = НайтиПоследПост(Док.Номенклатура,регистратор); 

Состояние("Заполнение выходной таблицы..."+Док.Номенклатура); 

Если Док.Количество <> 0 тогда 
ценаПр = Док.сумма / Док.Количество; 
Иначе 
ценаПр =0; 
КонецЕсли; 

ДоляМ = ((ценаПр-(поступилоПо*множитльСебестоимость) ) * ПроцентОТМаржи/100)*Док.Количество; 
ПечДоляМ = Формат(ДоляМ, "Ч015.2") ; 

ПечпоступилоПо = Формат(поступилоПо, "Ч015.2") ; 

Таб.ВывестиСекцию("строка"); 

ИтогСумма = ИтогСумма +Док.сумма; 
ИтогМ = ИтогМ + ДоляМ; 

КонецЦикла; 


КонецЦикла; 



// Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0); 
// Заполнение полей "Итого" 
Таб.ВывестиСекцию("Итого"); 
// Вывод заполненной формы 
Таб.ТолькоПросмотр(1); 
Таб.Показать("Сформировать", ""); 
КонецПроцедуры 


Процедура ПриОткрытии() 

ПроцентОТМаржи = 10; 
множитльСебестоимость = 1.25; 

Если глПользователь.наименование="Артур" Тогда 
ИначеЕсли глПользователь.наименование="Шах" Тогда 
Иначе 
// ВыбПользователь = глПользователь.текущийЭлемент(); 
// Форма.ВыбПользователь.Доступность(0); 

КонецЕсли; 

Заявки фрилансеров

8 месяцев назад
Денис Волошин
34 года, Украина
1 год в сервисе
Был онлайн 17 часов назад
8 месяцев назад
Виктор К.
38 лет, Украина
10 лет в сервисе
Был онлайн 1 месяц назад
8 месяцев назад
Леонид Рыбаков
49 лет, Россия
6 лет в сервисе
Был онлайн 5 месяцев назад
8 месяцев назад
Васильев Игорь
30 лет, Украина
1 год в сервисе
Был онлайн 21 час назад
7 месяцев назад
Владимир П.
34 года, Украина
5 лет в сервисе
Был онлайн 7 месяцев назад

Похожие заказы

Выгрузка 1с с сайта неработает нужно поправить

Выгрузка 1с с сайта неработает нужно поправить

Поправить сломанную синхронизацию с 1с

В 1 с работал скрипт который заливает товары в бд MYSQL на удаленном сервере, потом за ненадобностью синхронизация не использовалась, а как понадобилась оказалось что она не работает. Что то во общем сломалось ... Нужно поправить синхронизацию. Серве...

Отчёт: Взаиморасчёты с клиетами

Здравствуйте! У меня 1с 11.1 . Начал работать недавно и обнаружил что нет развернутог отчёта взаимрасчёиов с клиентами и поставщиками. Сможете сделать ?

Доработка 1с или продажа готового решения

Доработка 1с или продажа готового решения Терубемые сценарии для отработки - К примеру забиваем нового клиента, розничный или юрик. И в договор автоматом встает директор, на основании чего, сумма, и набор товара что покупает клиент То есть заполняем ...

Поправить синхронизацию заказов: 1С – Битрикс – Roistat

- Поправить синхронизацию изменения СТАТУСОВ заказов в 1С, а то неправильно работает. Если статус изменить в 1С, то он не меняется в Битрикс. - Еще есть баг: в 1С статус поступившего заказа меняем на "отменен", а через какое-то время этот з...

Написать небольшой отчет в 1С (УТП) по результатам продаж за период

Конфигурация 1С: Управление торговым предприятием для Украины", редакция 1.2. UPD: задача и прилагаемый файл немного изменены. Задача:Создать отчет по результатам продаж в разрезе ответственных менеджеров. Особенности:сумма прибыли берется из по...

В 1С 7.7 дополнить отчет по продажам сортировкой по типу цен

Добрый день, В 1С 7.7 дополнить отчет по продажам сортировкой по типу цен, Описание на приложенных картинках. Желательно срочно и так как задание ясное, просьба указывать цену и срок.

Настройка/создание отчёта в 1С 8.2

Необходимо настроить один из имеющихся в 1С версии 8.2 отчётов или создать новый для последующего использования сотрудниками компании. Подробное описание технического задания приведено на странице http://avtopandora.ru/tz.html. Крайне желателен личны...

Написать небольшой отчёт по взаиморасчётам в 1С (УТП)

Конфигурация: "Управление торговым предприятием для Украины", редакция 1.2. Задача: Создать отчёт по задолженностям контрагентов. Результирующие данные отчёта: - Контрагент - Сумма задолженности в грн - Сумма задолженности в у.е. - Дата пос...

Программист 1С 7.7

Необходимо посмотреть как давно было обновление релиза 7.7, и обновить 1С до актуального состояния. Обновить отчёты. Помочь с настройкой новой базы после смены юр лица (перенос данных) из одной в другую. Поправить скрипт, выгружающий данные в csv.