Богдан Костевич
17 лет, Украина
10 сообщений
#1 месяц назад
Ребята, помогите пожалуйста. Уже весь интернет перерыл, но подробной инструкции нигде нету, а я самоучка. Хочу подключить opencart (ocStore русская версия), но уже на 2 шаге мне пишет, что нету mCrypt. Я так понял нужно php выше, чем 7.1? Могли бы Вы рассказать как её установить и где скачивать (если это поможет решить основную проблему). Буду очень благодарен!!!!
Евгений К.
24 года, Украина
485 сообщений
Александр Ф.
35 лет, Россия
2180 сообщений
#1 месяц назад
gigbat, проблема не в php версии, а в том, что каждая php компиляция (сборка-установка) сопровождается выбором и подключением библиотек, модулей и расширений, вот одной из них в вашем окружении не хватает. Либо это проблема сервера, либо как предположил crus94 в вашей виртуальной среде. Перекомпилировать вряд ли удастся, поэтому меняйте окружение (ставьте другой веб сервер).
Богдан Костевич
17 лет, Украина
10 сообщений
#1 месяц назад
crus94, А если у меня уже есть хостинг и домен и я работаю только с XAMPP? Что делать?
regado, А как его поставить? Я просто только начал осваивать верстку.
Роман Беляев
33 года, Украина
15585 сообщений
онлайн
#1 месяц назад
Цитата (gigbat):
Я просто только начал осваивать верстку
Уже не только верстку. Гуглите, да обрящете. 
Евгений К.
24 года, Украина
485 сообщений
#1 месяц назад
gigbat, если у вас есть хостинг - напишите тех. поддержке с проблемой.
Богдан Костевич
17 лет, Украина
10 сообщений
#1 месяц назад
crus94, только моя верстка ещё не на хостинге, может ли это быть проблемой?
Евгений К.
24 года, Украина
485 сообщений
#1 месяц назад
gigbat, извините, не понимаю вас. )

Вы вроде изначально спрашивали о том, что у вас опенкарт не устанавливается. )

устанавливается сначала движок, а потом на него натягивается верстка.