Фрилансеры предложат решение вашей задачи уже через несколько минут!

Публикация заказа на фриланс бирже не займет много времени.

7 лет назад
Александр И.
36 лет, Россия
12 лет в сервисе
Был онлайн 9 дней назад
7 лет назад

Объединение данных в XLS.
Имеется таблица с данными, итог обработки - в новом 1 столбце "FOTO".

Что требуется:
Каждая строка - уникальный адрес объекта недвижимости. Для него может быть, а может и не быть фотография в столбцах справа, "images".

В этих ячейках содержатся имена фотографий, и некоторые дублируются.
Нужно, чтобы данные из ячеек справа были не только сцеплены в одну ячейку, но и, при этом, были удалены дубли имён файлов.
Все имена файлов заканчиваются ".jpg" если в конце данных ячейки или ".jpg," если в другом месте строки данных ячейки.

Пример, строка 3.
АДРЕС: Академика Павлова, 28
ФОТО 1: GED_15154144.jpg,GED_789464.jpg,GED_789465.jpg
ФОТО 2: GM_36901134.jpg,GM_79617267.jpg
ФОТО 3: GED_789463.jpg,GED_789464.jpg,GED_789465.jpg,GED_789466.jpg,GED_789467.jpg,GED_789468.jpg

После обработки, новый столбец, произошла сцепка данных и удаление дублей имён файлов фотографий, FOTO: GED_15154144.jpg,GED_789463.jpg,GED_789464.jpg,GED_789465.jpg,GED_789466.jpg,GED_789467.jpg,GED_789468.jpg,GM_36901134.jpg,GM_79617267.jpg



Часть 2.

Унификация данных адреса.
Задача: приведение формулой данных адреса к унифицированному виду для последующей обработки формулой =ИНДЕКС(A:F;ПОИСКПОЗ(E2;F:F;0);4) или =ВПР(A2;C:D;2;0) по первому выполненному тобой заданию анимации фотографиями по адресам, https://www.weblancer.net/projects/467534.html

В процессе приведения данных требуется последовательно выполнить цепочку замен, именно последовательно, к примеру: сначала удаляем сокращение "ул.", затем "корп." переименовываем в "К", ... удаляем пробелы в блоке номера строения и т.д. - все эти последовательные замены я в формулу вставлю сам, мне нужна лишь формула.

Соотв., рассмотрим пример для понимания:
Красина пер. 9Стр.2
Красина пер., 9С2
переулок Красина, д.9С2
- это один и тот же фактический адрес, но написан он по-разному. И его надо привести к унифицированному виду (без пробелов в части данных номера/ строения/ ): Красина пер.9С2

Выбранный исполнитель
Андрей З.
Андрей З. 
33 года, Украина
12 лет в сервисе
Был онлайн 6 лет назад
7 лет назад

$30

1 день

Отзыв заказчика
Работа была выполнена в соответствии с ТЗ. Её результаты меня порадовали и сильно облегчили работу.

Исполнитель интеллигентный, талантливый специалист.

Благодарю за сотрудничество!
  • Рекламное место свободно
  • Рекламное место свободно
Андрей З.
Андрей З. 
33 года, Украина
12 лет в сервисе
Был онлайн 6 лет назад
7 лет назад

Другие заказы в категории «Базы данных»